imagic

Подключение модуля imagick на Ubuntu

Модуль imagic сразу подключить не удалось.
Первой возникла ошибка: configure: error: not found. Please provide a path to MagickWand-config or Wand-config program.
Вторая же ошибка чисто орфографическая, нужно не забывать, что файлы в директории /etc/php5/apache2/conf.d должны все иметь расширение ini.

Устранилась первая ошибка предварительной установкой libmagick9-dev.

# apt-get install php-pear
# apt-get install php5-dev
# apt-get install libcurl3-openssl-dev
# apt-get install imagemagick libmagick9-dev
# pecl install imagick
# echo «extension=imagick.so» > /etc/php5/apache2/conf.d/imagick.ini
# /etc/init.d/apache2 restart

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *